0 votes
96 views

Preheated but after that when the ignitor gets red again to light the gas it doesnt preheat. Only couple years old. Ignitor is good. But the temperature will not pass 120F. Can diagnostic manuals for this unit

0 votes
135 views

the bake and the broil work but when I put it on self-clean the door will lock and go for about a min and then it will stop
I see the blue light labeled OVEN blink 4 times and the blue light labeled HEATING blink 3 times
please advise

  • zelik123 asked 6 months ago
  • last active 6 months ago
0 votes
134 views

electrode not firing. do smell the gas though. large oven does work.

  • mmab24mm asked 7 months ago
  • last active 7 months ago
0 votes
192 views

Error code 1006 on Thermador

  • jjwheels01 asked 8 months ago
  • last active 8 months ago
0 votes
459 views

This unit has a new noise when she put larger cookware. It doesn’t makes noise all the cookwares she has.
What part do we need to replace in order to fix this unit? If it is normal, what exponation should we give out?
Are there any suggested cookware we have to use? Do we have to use Thermador suggested cookwares?
Thank you.

  • Jushkim5 asked 1 year ago
  • last active 1 year ago
0 votes
453 views

Hi,
Do you guys have any experience with the error code I mentioned above?

0 votes
389 views

Customer stated that the temperature isn’t right. Some times pre-heating isn’t working. This unit has an issue with temperature sensor?

  • Jushkim5 asked 1 year ago
  • last active 1 year ago
0 votes
355 views

No coming out gas. The igniter is working good. What part we need to be replaced?

  • Jushkim5 asked 1 year ago
  • last active 1 year ago
1 vote
259 views

it makes little humming noise when we use the boost mode everywhere we put the cookware is this normal? or need to be replaced parts ?

  • Jushkim5 asked 1 year ago
  • last active 1 year ago
0 votes
302 views
  1. I would like to know if the drain pump that we need to replace for this unit fix the issue.
  2. How to open this unit to access the drain pump area?
    Thank you.
  • Jushkim5 asked 1 year ago
  • last active 1 year ago
0 votes
410 views

Hello Technicians, this is a follow up question, from my last question on this Thermador dishwasher.
I have checked all that was suggested from my last question on this product. Drain is clear and unobstructed. Wash arm spray nozzles are clear, detergent dispenser is working properly. Two things I have found ,when upper rack only is used and then you return to both racks the plunger that diverts water to the top rack sticks in the closed position and bottom spray arm does not work , I can take the spray arm off and take my finger and press the plunger down and the spray arm functions properly. I have also noticed the water in the tub is only 110 degrees. The flow through heaters do not come on and heat the water until about 30 minuets into the cycle, according to the service manual the dishwasher will pull 11 amps when The heaters are activated, the dishwasher pulls 1.5 amps for the first 25 to 30 minuets of both normal and heavy wash cycles. Can you advise me on how long into the cycle is normal for the heaters to begin operation and also the best way to stop the plunger from sticking. Any advise is appreciated.

  • billtilley asked 2 years ago
  • last active 2 years ago
0 votes
316 views

Hello Technicians,I have a Thermador Dishwashe that is not cleaning the dishes on the bottom rack or top rack . Dishes don’t look like they have washed at all. I thought it could be a low water issue, so I had the customer add hot water when the dishwasher stoped drawing water going into the beginning of the cycle, they said it didn’t make a difference. Please advise as to what else I might check. I have checked and cleaned spray arms, have Shop vacuumed out sump and drain. Thank you for you advise and help.

  • billtilley asked 2 years ago
  • last active 2 years ago
0 votes
402 views

Door handle coming apart and did not notice any screws or how to adjust it can I get a service manual Or something showing me how to repair the door handle and bottom hinge most importantly the doorhandle that’s the one I couldn’t figure out although I have fixed many

0 votes
485 views

Original igniter took a A long time to ignite so replaced it with generic Electrolux igniter 5303935066 And it died three days later so I can replace it again and noticed that when Igniting it starts off really bright in the center with a tiny little spark and makes a slight little buzz but seems to be cycling on and off on and it lasted for the customer for couple days .. could it be the igniter type, safety valve, or maybe thermostat? I had this issue one other time with a jennair where (oem) igniter kept burning out for unknown reasons..??

0 votes
340 views

Ice selected On panel. Water filter just replaced. Cube tray full with frozen ice but stopped dispensing and seems almost like it’s jammed. Can I please get full technicians manual I want to see how to run a diagnostic.

0 votes
592 views
1 vote
613 views

Ice cube trays seem to have a little bit of frozen water in them, when I disconnected the water filter and reconnected it it made a gushing noise like the valve is good in the water is making its way to the filter. There is only a icemaker no water dispenser but there are two little valves on one bracket Both tested good for 1100 ohms of resistance. I have no idea how to diagnose this ice machine it’s like 180 from Bosch so I don’t want to miss diagnosed this issue since the display had a ICE button on it but when I clicked it and held the door switch nothing happened. The ice machine part was 00744441

1 vote
1k views

Ice filter not changed in two years and existing small amount of cubes are small.

What is the method to cycle ice maker and perform test:

I will assume I have to fix a defrost thermostat/thermistor assembly. I need to be able to test and disassemble freezer back panel and ice maker Dissasembly.

  • Guest asked 2 years ago
  • last active 2 years ago
0 votes
797 views

Need some extra eyes to take a look at this. Hopefully I can attach the information that is needed to try to determine how to properly wire this up.
Model of inline blower is VTI1010D

The hood and inline blower were installed in a house. New owner didn’t like it. Builder had it taken out and installed in another house. There is a connecting wire harness that runs between units. Naturally
that wiring harness could not be removed from original house. Electrician cut off the connecting end plugs to be able to match up wires. He wired it up and it don’t work. Builder saved the connecting ends, but that don’t help because
electrician took cut off wires out of plugs.

I have acquired information on wiring diagrams and schematics for hood and blower. I also find conflicting differences.
Here’s what I have come up with.

White wire from hood connects to blue wire at blower.
Brown wire from hood connects to brown wire at blower.
Red wire from hood connects to white wire at blower.
Blue wire from hood connects to red wire at blower.

Thanks in advance

0 votes
6k views

CUSTOMER SAYS THAT THEY HIT POWER BUTTON, IT STAYS ON FOR BRIEF MOMENT AND THEN SHUTS OFF. THEY HAVE TO PRESS THE POWER BUTTON AIN TO KEEP TURNING IT ON.
ERROR CODE F34 COMES ON AFTER POWER FADES. Tried to test power line going into unit to main board but not sure if low voltage should be present.

  • Guest asked 3 years ago
  • last active 3 years ago
0 votes
710 views

I’m working on a Thermador range issue is with the top burners all igniters are working fine but the gas takes very long to open ( can’t hear it) , same issue with the griddle except that on this one you can see the spark going off before the gas comes on ,no flame , it looks like out of sync. I check the burner holes all are clean ,the issue is the gas is not heard until several clicks later. Any ideas or a manual for this one?

0 votes
680 views

looking for some help on this dishwasher that I went out on it couple of days ago customer had two other companies out . Unit was full filthy water . I put to drain and cleaned it out , also cleaned filter . Restarted unit it filled and didn’t wash sounded like it was draining some water out but nothing else. Found no tech sheet with unit. Ordered circulation pump when out and install put unit still doing same thing. I am not very familiar with this brand, any help would be appreciated. Thanks

0 votes
657 views

Hi Folks,

A Happy & Safe Fourth to all!

This unit is in very good condition and the problem element has not been used that much. Facing the unit it is located on the lower left, smallest element of the bunch. You turn the switch to the on position and the element switch lights up. Set the heat temperature and that lights up too. But no heat at all. Now I took the cooktop out and the element tests okay. Actually there is no wear at all on the element. Looked for disconnected wire(s) found none. Really don’t know where to go from here. Where is a good place to get a break down of Thermador products? Looking for some expertise from the Video Family.

Thank you,
Jan
Barney’s Appliance
Palm Bay, FL

  • Guest asked 3 years ago
  • last active 3 years ago
1 vote
1k views

Customer says that the burner does not light when they activate the cooktop control.
Usually I clean the burner end holes to ensure that they have clear path for flame.
But it may be different issue for thermador. Would there be an igniter switch in the control portion
that I may not be aware of ?

  • Guest asked 3 years ago
  • last active 3 years ago
0 votes
2k views

I have a Thermador built in refrigerator with a evaporator leak. The unit was built by Kitchen aid. I know the Kitchen Aid evaporator and heat exchanger are 1/2 to 1/3 the price of the Thermador parts. Does anyone know where I can find the Whirlpool part number for these parts or maybe get the equivilant model number.

Thanks
Mark Kelly
Kelly’s Appliance Center

  • Guest asked 3 years ago
  • last active 3 years ago
0 votes
1k views

Any idea what error this could be ?

0 votes
2k views

Looking for two Thermador hinges part # 00488417
Any help would be appreciated

Showing 1 - 30 of 33 results